Saturday, April 24, 2010

OFM in a cluster with Http Server

I had set up a SOA cluster using Enterprise Deployment Guide      

As advised in the guide, we also have an http server proxying the request to one of the 2 SOA Servers in the domain.

Then went up and made appropriate changes in mod_wl_ohs.conf file.

So far so good.Everything now is accessible from the same url. 

But when i went on to create an application server connection in jdeveloper either with Admin server port or http port, all it said was.
Testing JSR-160 Runtime ... failed.
Cannot establish connection.
Testing JSR-160 DomainRuntime ... skipped.
Testing JSR-88 ... skipped.
Testing JSR-88-LOCAL ... skipped.
Testing JNDI ... skipped.
Testing JSR-160 Edit ... skipped.
Testing HTTP ... success.
Testing Server MBeans Model ... skipped.

Searched on internet. There was no solution. Every where it said, to remove any proxy in Jdeveloper, or have the same proxy as in browser.Since i was able to connect to admin server using browser.

The resolution is to have the proxy in the browser. Proxy is the http server that you have setup before. After that while creating the connection, create it on Admin Server.

and then
Testing JSR-160 Runtime                ... success.
Testing JSR-160 DomainRuntime          ... success.
Testing JSR-88                         ... success.
Testing JSR-88-LOCAL                   ... success.
Testing JNDI                           ... success.
Testing JSR-160 Edit                   ... success.
Testing HTTP                           ... success.
Testing Server MBeans Model            ... success.

8 of 8 tests successful.